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Windows云服务器辅助网卡问题排查与处理

最近更新时间:2026-06-17 15:51:32

问题描述

在金山云 Windows 云服务器上,通过控制台挂载了辅助网卡,并为该辅助网卡绑定了弹性 IP(EIP)。绑定完成后,从外部网络(或本地计算机)执行 ping 弹性IP 命令,出现“请求超时”或“目标主机不可达”等提示,无法正常收到 ICMP 回显应答,即弹性 IP 无法被 Ping 通。

可能原因

  1. 安全组未放行 ICMP 协议。

  2. 弹性 IP 绑定状态异常。

  3. 辅助网卡未在系统内正确配置 IP。

  4. 多网卡路由优先级(跃点数)问题。

排查步骤

  1. 登录网络控制台,查看弹性IP绑定状态,且不处于异常状态(到期/欠费)。

  2. 登录云服务器控制台,进入实例详情页,查看安全组状态,需要放通ICMP协议。

  3. 连接Windows云服务器,查看系统防火墙(若没有使用过或者关闭的可以忽略),找到 "文件和打印机共享 (回显请求 - ICMPv4-In)" 规则需启用。

  4. 查看系统内部辅助网卡的配置。

  5. 登录云服务器控制台,再次检查网关信息,需要与上一步检查结果相同。

  6. 检查活跃路由在辅助网卡的配置,重点看跃点数(常见)。

    route print

解决方案

原因一:弹性IP状态异常

弹性ip状态异常,请在弹性IP控制台查看是何种异常,若是欠费或者到期,需要续费或者重新购买

原因二:安全组没有开放端口

  1. 检查该网卡绑定的入站规则,确认必要的业务端口已开放。

  2. 若需快速测试连通性,可先放行 ICMP 协议,源 IP 填写本地 IP,执行 ping 测试。

  3. 使用 telnet <弹性IP> <业务端口> 验证端口连通性。

原因三:系统防火墙的屏蔽(少见)

完成好原因二的步骤后,可以先关闭系统防火墙再测试。

原因四:辅助网卡在系统内配置错误

ipconfig /all

输出网卡详细配置,对应云平台看是否正确。

如果主网卡和辅助网卡都有默认网关,Windows 系统会随机选择一个作为默认出口,导致网络不稳定或主网卡上网异常,所以无需进行手动配置辅助网卡的默认网关,自动获取即可。

原因五:策略路由缺失

原因四中提到在辅助网卡的 TCP/IPv4 属性里直接填写默认网关,会导致两个默认网关,主网卡的外网访问会出现间歇性中断。

如果需要做到从辅助网卡进来的数据包从辅助网卡回去,需要通过策略路由。

  1. 查看网卡接口,查看对应的辅助网卡并记录辅助网卡Idx值。

    netsh interface ipv4 show interfaces
  2. 查看当前活跃路由状态,注意跃点数。

    route print
  3. 添加辅助网卡默认路由(注意跃点数要比主网卡高)。

    route add [-p] 0.0.0.0 mask 0.0.0.0 192.168.97.1 metric 200 if 33

    添加完成后路由表显示:

    若要删除则执行如下命令即可,指定 -p 参数,可永久性删除相应路由参数。

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