设定默认策略版本

最近更新时间:2020-12-03 16:38:55

查看PDF

设定默认策略版本(SetDefaultPolicyVersion)

描述

设定指定策略的默认策略版本

注1:修改自定义策略的默认策略版本会对所有附加该策略的实体(IAM本期只有“用户”一种实体)产生影响,可通过ListEntitiesForPolicy接口查询一个策略的附加实体。

请求参数

名称 类型 必须 长度限制(字符) 参数格式 描述
Action String 确定值 [a-zA-Z]+ 操作接口名,系统规定参数,取值:SetDefaultPolicyVersion
PolicyKrn String 最短是25,最长2048 格式:krn:ksc:iam::account-id:policy/policy-name 待设定默认策略版本的策略标识
VersionId String 最短2 v[1-9][0-9]* 待设定为默认版本的策略版本Id

返回元素(调用成功)

错误码(调用不成功)

错误代码(Code) 错误消息(Message) HTTP 状态码 中文描述(语义)
InvalidParameterValue An value must be supplied for the input parameter %s. 400 输入参数%s的值不能为空,具体参数名在%s说明
InvalidParameterValue An invalid or out-of-range value was supplied for the input parameter %s. 400 输入参数 %s的值无效、不合法或者超出范围,具体参数名在%s说明
PolicyNoSuchEntity The request was rejected because it referenced ‘Policy’ that does not exist. 404 请求被拒绝,因其引用的“策略”不存在
PolicyVersionNoSuchEntity The request was rejected because it referenced ‘PolicyVersion’ that does not exist. 404 请求被拒绝,因其引用的“策略版本”不存在

示例(调用成功)

请求示例
https://iam.api.ksyun.com/?Action=SetDefaultPolicyVersion
&PolicyKrn=krn:ksc:iam::12345678901234567890:policy/IAMadmin
&VersionId=v2
&公共请求参数
返回示例
  • XML格式
<SetDefaultPolicyVersionResponse>
    <ResponseMetadata>
        <RequestId>ea6a0dbc-c26d-4085-87ad-45118564ada2</RequestId>
    </ResponseMetadata>
</SetDefaultPolicyVersionResponse>
  • JSON示例
{
  "ResponseMetadata": {
    "RequestId": "0d4a742d-76ec-40d5-b5b8-839ed515a833"
  }
}

文档内容是否对您有帮助?

根本没帮助
文档较差
文档一般
文档不错
文档很好

在文档使用中是否遇到以下问题

  • 内容不全,不深入
  • 内容更新不及时
  • 描述不清晰,比较混乱
  • 系统或功能太复杂,缺乏足够的引导
  • 内容冗长

更多建议

0/200

评价建议不能为空

提交成功!

非常感谢您的反馈,我们会继续努力做到更好!

问题反馈