删除策略版本内容

最近更新时间:2020-12-03 17:00:15

查看PDF

删除策略版本内容(DeletePolicyVersion)

描述

删除指定策略的特定策略版本的内容

注1:金山云账户只能删除自定义策略的策略版本内容,不能够删除系统策略的策略版本内容;且只能删除非默认策略版本,默认策略版本在调用DeletePolicy接口删除策略时被一并删掉。

请求参数

名称 类型 必须 长度限制(字符) 参数格式 描述
Action String 确定值 [a-zA-Z]+ 操作接口名,系统规定参数,取值:GetPolicyVersion
PolicyKrn String 最短是25,最长2048 格式:krn:ksc:iam::account-id:policy/policy-name 待删除策略版本的策略的唯一标识
VersionId String 最短2 v[1-9][0-9]* 待删除的策略版本Id
返回元素(调用成功)

错误码(调用不成功)
错误代码(Code) 错误消息(Message) HTTP 状态码 中文描述(语义)
InvalidParameterValue An value must be supplied for the input parameter %s. 400 输入参数%s的值不能为空,具体参数名在%s说明
InvalidParameterValue An invalid or out-of-range value was supplied for the input parameter %s. 400 输入参数 %s的值无效、不合法或者超出范围,具体参数名在%s说明
PolicyNoSuchEntity The request was rejected because it referenced ‘Policy’ that does not exist. 404 请求被拒绝,因其引用的“策略”不存在
PolicyVersionNoSuchEntity The request was rejected because it referenced ‘PolicyVersion’ that does not exist. 404 请求被拒绝,因其引用的“策略版本”不存在
PolicyAccessDenied The request was rejected because it attempted to attach a ‘Policy’ that you have no permission. 409 不能删除非属于本账户的自定义策略版本
PolicyDefaultVersionDeleteConflict The request was rejected because it attempted to delete a ‘PolicyVersion’ that is the default version of the ‘Policy’. 409 不能删除默认策略版本

示例(调用成功)

请求示例
https://iam.api.ksyun.com/?Action=DeletePolicyVersion
&PolicyKrn=krn:ksc:iam::12345678901234567890:policy/IAMadmin
&VersionId=v2
&公共请求参数
返回示例
  • XML格式
<DeletePolicyVersionResponse>
    <ResponseMetadata>
        <RequestId>c00e9637-dfe8-44f1-9ac9-2df57b48f0c2</RequestId>
    </ResponseMetadata>
</DeletePolicyVersionResponse>
  • JSON示例
{
  "ResponseMetadata": {
    "RequestId": "ae246270-cab5-4b48-8c0b-1645b7f6d0ad"
  }
}

文档内容是否对您有帮助?

根本没帮助
文档较差
文档一般
文档不错
文档很好

在文档使用中是否遇到以下问题

  • 内容不全,不深入
  • 内容更新不及时
  • 描述不清晰,比较混乱
  • 系统或功能太复杂,缺乏足够的引导
  • 内容冗长

更多建议

0/200

评价建议不能为空

提交成功!

非常感谢您的反馈,我们会继续努力做到更好!

问题反馈